AI Agent Calls not connecting

Incident Report for Regal AI

Resolved

The incident has been resolved
Posted Oct 31, 2025 - 18:09 EDT

Monitoring

A fix has been implemented and we are monitoring
Posted Oct 31, 2025 - 17:47 EDT

Investigating

We are currently investigating an issue with AI agent calls not connecting on our platform.
Posted Oct 31, 2025 - 17:34 EDT
This incident affected: AI Agents (AI Agents platform).