The AWS outage affecting the US-EAST-1 Region have been fully restored, and all dependent service providers are nearing full operations. Stemming from these service outages, Regal's platform & user interface have recovered and are now accessible. As part of the AWS recovery process, there continue to be intermittent issues as they process backlog requests which will finish processing over the next few hours. We will continue to monitor these back-end services and will report back with further updates.
Posted Oct 20, 2025 - 20:33 EDT
Update
We are continuing to experience service disruptions due to the AWS outage affecting the US-1 Region. While recovery is underway and progressing, we continue to encounter related service issues impacting Regal's core products. We are monitoring the situation closely and will continue to provide an updates.
Posted Oct 20, 2025 - 18:27 EDT
Update
We are continuing to experience service disruptions due to the AWS outage affecting the US-1 Region. While recovery is underway, we are noticing elevated outages resulting from residual network connectivity issues, impacting Regal's core services. We will continue to implement mitigation actions on our side but please be advised that service is currently disrupted. We will provide updates as soon as possible.
Posted Oct 20, 2025 - 16:08 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 16:07 EDT
Update
We are continuing to experience service disruptions due to the AWS outage affecting the US-1 Region. While recovery is underway, we are noticing elevated outages resulting from residual network connectivity issues, impacting Regal's core services. We will continue to implement mitigation actions on our side but please be advised that service is currently disrupted. We will provide updates as soon as possible.
Posted Oct 20, 2025 - 15:41 EDT
Update
AWS has identified the issue that has caused the network connectivity issues in the US-EAST-1 Region and are continuing to apply mitigation efforts to recover AWS services. This has resulted in downstream performance degradation in key services including Programmable Voice, Messaging and Task Router services. We will continue to provide updates on recovery from the AWS incident.
Posted Oct 20, 2025 - 13:26 EDT
Update
AWS has identified the issue that has caused the network connectivity issues in the US-EAST-1 Region. This has resulted in downstream degradation in performance into multiple product motions within Regal. We will continue to provide updates on next steps.
Posted Oct 20, 2025 - 11:29 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:40 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:25 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 09:44 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 09:43 EDT
Identified
We are continuing to monitor the AWS Outage that has impacted the US-EAST-1 Region. AWS has reported some improvement with error rates and latencies. Additionally, please be advised that the outage has also impacted other Twilio products that power downstream platform functionality as well. We will continue to provide updates as we receive new information.
Posted Oct 20, 2025 - 09:45 EDT
This incident affected: Contact Center (Agent Desktop, Task Routing, Login / SSO, Journey Triggers, Journey Campaign Actions (SMS/Call)), Platform (APIs, Ingest, In-App Reporting), AI Agents (AI Agents platform), and Vendors (Twilio (SMS), Twilio (Voice)).