Calls Intermittently Failing

Incident Report for Regal AI

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 14:42 EDT

Identified

The issue is ongoing due to a problem with one of our upstream providers, Twilio. We are actively monitoring the situation and will provide updates as soon as more information becomes available from Twilio. You can track their status directly at status.twilio.com.
Posted Mar 31, 2025 - 12:40 EDT

Investigating

We are currently investigating reports of calls intermittently failing. As of now, this seems to be affecting inbound and transfer calls.
Posted Mar 31, 2025 - 12:29 EDT
This incident affected: Agent Experience / Contact Center (Agent Desktop) and Telephony (Twilio (Voice)).