Twilio Outage - Text and Call Task Errors

Incident Report for Regal AI

Resolved

Twilio is reporting that this incident has been resolved.
Posted Apr 17, 2025 - 19:16 EDT

Monitoring

Twilio has deployed a fix and is seeing signs of recovery.

We will continue to monitor the situation and provide further updates once Twilio has confirmed the issue is fully resolved.
Posted Apr 17, 2025 - 18:15 EDT

Update

Twilio has acknowledged the problem and their engineering team is actively investigating.

We will continue to monitor the situation and provide further updates once Twilio has confirmed the issue is fully resolved.
Posted Apr 17, 2025 - 16:23 EDT

Update

We are continuing to investigate this issue.
Posted Apr 17, 2025 - 16:20 EDT

Investigating

We're currently experiencing issues with sending SMS messages and Task Wrapping due to an incident impacting our provider, Twilio.

We’re monitoring the situation closely and will share updates as they become available. Thank you for your patience.
Posted Apr 17, 2025 - 16:00 EDT
This incident affected: Agent Experience / Contact Center (Agent Desktop) and SMS (Twilio (SMS)).